Endian travando todos os dias.

Home Comunidade Brasileira Endian Firewall Endian Firewall Endian travando todos os dias.

Este tópico contém respostas, possui 2 vozes e foi atualizado pela última vez por  alexandremetz 1 semana, 6 dias atrás.

  • Autor
    Posts
  • #22084

    alexandremetz
    Participante

    Olá, tenho o Endian 3.2.2 Community instalado com 20 usuários ativos. Utilizo proxy não transparente com autenticação por usuário e senha, o firewall está habilitado e bloqueando o acesso pelas portas 80 e 443. Agora vem o problema, todos os dias entre 12:30 e 13:00 o Endian simplesmente para, as maquinas com acesso via proxy perdem acesso a internet, as maquinas liberadas do proxy e do firewall continuam com acesso. Quando isso ocorre não consigo acessar o endian nem pelo navegador e nem pelo ssh, a única forma de resolver é indo até a maquina e via shell reiniciar o endian. Não sei mais o que fazer. Me ajudem.

  • #22085

    Ricardo
    Participante

    Alexandremetz,
    Você consegui visualizar o conteúdo do cache.log do Squid ?
    Verifique o que foi registrado no log, no momento em que começou a travar.

  • #22086

    alexandremetz
    Participante

    Vou verificar e posto o que achei.

  • #22091

    alexandremetz
    Participante

    Ricardo;
    O erro que aparece na última linha é o seguinte:
    2017/08/03 12:00:57 kid1l essential ICAP service is down after an options fetch failure: icap://127.0.0.1:1344/url_check [down, !opt].
    Depois dessa linha não há mais nada.

  • #22092

    Ricardo
    Participante

    Alexandre, este erro indica que o serviço do c-icap (filtro de conteudo web) está sendo interrompido.
    Mostre nos o conteudo do arquivo:
    # cat /var/log/c-icap/server.log

  • #22093

    alexandremetz
    Participante

    Segue imagem que o comando me retornou.

    c-icap

    • Esta resposta foi modificada 2 semanas atrás por  alexandremetz.
  • #22097

    Ricardo
    Participante

    Hoje me deparei também, com esta informação no log do c-icap:
    “Registry ‘virus_scan::engines’ does not exist!”
    Ele esta reclamando da engine do antivirus Clamd.

    Aqui eu deixo desativado o antivírus para filtragem web.
    Mas caso queira eliminar este erro apresentado no log, siga estes passos:
    No menu proxy, aba Webfilter, altere algum profile criado e marque a opção “Activate Antivirus Scan” e salve em seguida.

    Você também pode turbinar o C-icap.
    Faça uma copia do arquivo antes de edita-lo.

    # nano /usr/lib/efw/icap/default/settings

    Dependendo da quantidade de usuários conectados no proxy, deixe os valores conforme abaixo:

    MAX_SERVERS=7
    START_SERVERS=5
    THREADS_PER_CHILD=50
    CICAP_LOG_ROTATE=
    MAX_MEM_OBJECT=2097152

    Reinicie os serviços:

    # /etc/init.d/c-icap restart
    # /etc/init.d/squid restart

    Continue monitorando o server.log do c-icap.

  • #22098

    alexandremetz
    Participante

    Fiz essas mudanças, amanha te aviso se resolveu o problema do c-icap parar.
    Eu também não uso o clamd ativado, mas vou deixar em duas regras para ver o que acontece.
    Mas por hora obrigado.

  • #22099

    alexandremetz
    Participante

    Ricardo,
    Parece que suas dicas surtiram efeito, não tive problemas hoje.
    Agradeço os concelhos, obrigado.

Você deve fazer login para responder a este tópico.